in

andy vt's tools & blog

automating lazy

W7DTBAddinSetupX64.msi v1008r4 fails install on Windows 8, rolls back

Last post Thu, Feb 28 2013 7:47 PM by kerbs17. 9 replies.
Page 1 of 1 (10 items)
Sort Posts: Previous Next
  • Mon, Feb 4 2013 2:23 PM

    W7DTBAddinSetupX64.msi v1008r4 fails install on Windows 8, rolls back

    Tried installing W7DTBAddinSetupX64.msi version 1008R4 on my Windows 8 pc and it fails during install. The installer says there is a fatal error and rolls back. I have other mce plugins installed and they are working fine: centon, and powerdvd. I have been only using your commercial skip plugin and not the DVRMSToolbox, I have other software which manages ComSkip.exe.
    Filed under: , ,
  • Tue, Feb 5 2013 12:27 PM In reply to

    • babgvant
    • Top 10 Contributor
    • Joined on Mon, Oct 2 2006
    • United Kingdom

    Re: W7DTBAddinSetupX64.msi v1008r4 fails install on Windows 8, rolls back

    Does it tell you anything useful when it fails?
  • Tue, Feb 5 2013 3:41 PM In reply to

    • babgvant
    • Top 10 Contributor
    • Joined on Mon, Oct 2 2006
    • United Kingdom

    Re: W7DTBAddinSetupX64.msi v1008r4 fails install on Windows 8, rolls back

  • Tue, Feb 5 2013 10:43 PM In reply to

    Re: W7DTBAddinSetupX64.msi v1008r4 fails install on Windows 8, rolls back

    Thanks, for the quick response. Found you can turn on .Net 3.5 which includes 2.0 in Windows 8... more on it here: http://msdn.microsoft.com/en-us/library/hh506443.aspx The install of v1008r5 was successful. It wants to reboot right now, but it will have to wait till the morning when shows are not being recorded ;) Also Note: To others installing, since this is "unknown publisher" windows 8 blocks the install, select "More Info..." link and press the install anyway button.
    Filed under: ,
  • Wed, Feb 6 2013 10:05 AM In reply to

    Re: W7DTBAddinSetupX64.msi v1008r4 fails install on Windows 8, rolls back

    I tested out dtbaddin after rebooting my pc this morning and it is working fine. Thanks for your help.
  • Wed, Feb 27 2013 10:48 PM In reply to

    • kerbs17
    • Top 500 Contributor
    • Joined on Tue, Feb 26 2013

    Re: W7DTBAddinSetupX64.msi v1008r4 fails install on Windows 8, rolls back

    I'm having the exact same problems. I already had .net 3.5 installed (w/2.0). The latest installer does the roll back and provides no useful message.
  • Thu, Feb 28 2013 6:07 AM In reply to

    • babgvant
    • Top 10 Contributor
    • Joined on Mon, Oct 2 2006
    • United Kingdom

    Re: W7DTBAddinSetupX64.msi v1008r4 fails install on Windows 8, rolls back

    You don't need 3.5 installed for it to install properly anymore.

    Can you do a logged msiexec install? That should provide a hint as to why it's failing.

     

  • Thu, Feb 28 2013 8:02 AM In reply to

    • kerbs17
    • Top 500 Contributor
    • Joined on Tue, Feb 26 2013

    Re: W7DTBAddinSetupX64.msi v1008r4 fails install on Windows 8, rolls back

    Here's a message I see in the log: CAQuietExec: Microsoft (R) .NET Framework Installation utility Version 1.1.4322.573 CAQuietExec: Copyright (C) Microsoft Corporation 1998-2002. All rights reserved. CAQuietExec: CAQuietExec: Exception occurred while initializing the installation: CAQuietExec: System.BadImageFormatException: The format of the file 'MCEState.dll' is invalid.. CAQuietExec: Error 0xffffffff: Command line returned an error. CAQuietExec: Error 0xffffffff: CAQuietExec Failed CustomAction CA_MceState_Register returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox) Full Log Attached
  • Thu, Feb 28 2013 8:52 AM In reply to

    • babgvant
    • Top 10 Contributor
    • Joined on Mon, Oct 2 2006
    • United Kingdom

    Re: W7DTBAddinSetupX64.msi v1008r4 fails install on Windows 8, rolls back

    Do you have ,NET 1.1 installed?

    Looks like it's finding that InstallUtil.exe.

  • Thu, Feb 28 2013 7:47 PM In reply to

    • kerbs17
    • Top 500 Contributor
    • Joined on Tue, Feb 26 2013

    Re: W7DTBAddinSetupX64.msi v1008r4 fails install on Windows 8, rolls back

    Yep, uninstalling .net 1.1 fixed the issue. Thanks for your help!
Page 1 of 1 (10 items)
@2008 andy vt
Powered by Community Server (Non-Commercial Edition), by Telligent Systems