in

andy vt's tools & blog

automating lazy

WTV files with AAC

Last post Sun, Dec 4 2011 3:28 PM by marvin-miller. 5 replies.
Page 1 of 1 (6 items)
Sort Posts: Previous Next
  • Thu, Jul 21 2011 7:25 AM

    • murmy
    • Top 500 Contributor
    • Joined on Sat, Dec 9 2006

    WTV files with AAC

     

    In windows media center, I'm recording programs with a Hauppauge Colosus.Depending on the source (or whatever), it will create two types of wtv files - (H264 + AC3) and (H264 + AAC).

    In DTB, I've created a profile that uses Mencoder directly to convert to AVI (apparently, mencoder can now hande WTV (h264) files directly. I downloaded the latest athlon build from here: http://oss.netfarm.it/mplayer-win32.php). When an WTV file with AC3 is encountered, no problem, mencoder runs and it converts to AVI, renames the file and the profile completes as expected.

    However, and this is where I'm having a problem, when it encounters a WTV file with AAC, things just seem to get hung up. I can see mencoder kicking off and running its usual steps, but mencoder just seems to pause. It's still running because I see it in task manager but it's just not doing work. Since the profile was actually started, I know that throttling is not the issue. It seems more like mencoder is stuck waiting for something or something is blocking it. Because if I manually kill DVRMStoMPEG.exe in task manager, then mencoder will all of a sudden start encoding. There is something going on between DTB and mencoder, but only in the case where AAC is in the source file. I think mencoder uses libfaac to deal with AAC encoded files and somehow DTB does not like how this library is being used. This is just a guess.

    I'm hoping that Andy or someone else can offer a tip on why this might be happening.


     Thanks

    Using DTB 1.2.2.4 on Windows 7 32 bit, mencoder 33883 (athlon build from http://oss.netfarm.it/mplayer-win32.php)


     

  • Thu, Jul 21 2011 9:04 AM In reply to

    Re: WTV files with AAC

    I'm not sure how your calling mencoder, but could you try calling it using the run external no status action.  See if that works for you.
  • Thu, Jul 21 2011 12:12 PM In reply to

    • murmy
    • Top 500 Contributor
    • Joined on Sat, Dec 9 2006

    Re: WTV files with AAC

    I was using the regular RunExternal, but I switched to the RunExternal no status and that seems to have fixed it. Thanks!

    I can no longer see the status of the currently processing file, but I don't usually sit there and watch it anyways - only when I'm debugging.


  • Sat, Jul 23 2011 12:22 AM In reply to

    • margie
    • Not Ranked
    • Joined on Sat, Jul 23 2011

    Re: WTV files with AAC

     I am using Bigasoft WTV to AVI Converter.I have no problem of converting WTV with AAC to AVI. You can download the software to check.

  • Tue, Jul 26 2011 10:43 AM In reply to

    Re: WTV files with AAC

    It actually has to do with the way these actions work and isn't a quick fix.
  • Sun, Dec 4 2011 3:28 PM In reply to

    Re: WTV files with AAC

    Murmy - if you're still out there could I get a copy of your profile?

     I too am using a Collosus and (so far) am at a loss as to what to do with the files. Ultimately my goal is to be able to cut the commercials from the existing file and then fix the slider and splice 'em back together (just like with dvr-ms files) but anything, even just trancoding them, would be a good start for me :-)

Page 1 of 1 (6 items)
@2008 andy vt
Powered by Community Server (Non-Commercial Edition), by Telligent Systems