in

andy vt's tools & blog

automating lazy

Newbie - WMC not skipping commercials with Showanalyzer

Last post Fri, Apr 2 2010 7:41 AM by dabl. 8 replies.
Page 1 of 1 (9 items)
Sort Posts: Previous Next
  • Sun, Mar 28 2010 12:19 PM

    • Mike F-NY
    • Not Ranked
    • Joined on Sun, Mar 28 2010
    • Lindenhurst, NY

    Newbie - WMC not skipping commercials with Showanalyzer

     Hi Andy,

    Newbie here.  I have been following the step by step instructions for installing DVRMSToolbox1221-R4, DTBAddin and ShowAnalyzerSuite that Ben Drawbaugh laid out on the EngadgetHD website.  It looks like ShowAnalyzer is creating the applicable XML files in my C:\Users\Public\DvrmsToolbox\CommercialsXml\ folder but WMC does not skip commericals.  According to the FWLog (shown below), I am getting a message "No commercials found", yet the XML files are clearing showing marked commercial segments.  BTW, I am running in Windows 7 64-bit mode.  

    Being a newb to WMC, DVRST and ShowAnalyzer I have probably overlooked something that is very obvious but, after several attempts to install (with numerous reboots along the way), I keep striking out. Any help would be appreciated.  Here is a copy of the FWLog  and the XML file for the NBC show "Parenthood":

    Start Process: 3/28/2010 : 12:20 PM
    InputFile=C:\Users\Public\Recorded TV\Parenthood_WNBCDT_2010_03_27_19_59_00.wtv
    Processing actions, this may take some time!!
    Current Affinity: 255 System Mask: 255
    Getting MetaData
    Testing "Processed Files"
    Testing "Every Sage File"
    Testing "Every File"
    "Every File" is a match.
    Run Profile = nativecommdetect
    ProcessId = 5824
    DvrmsToolbox Version: 1.2.2.1
    Throttle DVRMStoMPEG
    FWThrottle: C:\Users\Public\Recorded TV\Parenthood_WNBCDT_2010_03_27_19_59_00.wtv
    WaitTime: 0 PollTime
    Duration = 00:00:00.0062501
    Waiting for available worker: 3/28/2010 12:20 PM
    Worker allocated: 3/28/2010 12:20 PM
    Get Video Information
    1920x1080 : 1920x1080 ATSC=True
    Duration = 00:00:00.4920132
    Find Commercials in file
    Create Analyzer: ShowAnalyzer
    Use Comskip
    Using comskip
    Running comskip this may take a while.
    Run C:\Program Files (x86)\DVRMSToolbox\Applications\comskip.exe "C:\Users\Public\Recorded TV\Parenthood_WNBCDT_2010_03_27_19_59_00.wtv" "C:\Users\Public\DvrmsToolbox\CommercialsXml"

    Finished Commercial Detectection
    No commercials found
    Action did not complete successfully
    Total Duration = 00:00:15.1950010

    PW Exit: System.InvalidOperationException: No process is associated with this object.
       at System.Diagnostics.Process.EnsureState(State state)
       at System.Diagnostics.Process.get_HasExited()
       at System.Diagnostics.Process.EnsureState(State state)
       at System.Diagnostics.Process.get_ExitCode()
       at Durrant.DVRMSFileWatcher.ProcessWrap.ap_Exited(Object sender, EventArgs e)
    Start Process: 3/28/2010 : 12:23 PM
    InputFile=C:\Users\Public\Recorded TV\Parenthood_WNBCDT_2010_03_27_19_59_00.wtv
    Processing actions, this may take some time!!
    Current Affinity: 255 System Mask: 255
    Getting MetaData
    Testing "Processed Files"
    Testing "Every Sage File"
    Testing "Every File"
    "Every File" is a match.
    Run Profile = nativecommdetect
    ProcessId = 2208
    DvrmsToolbox Version: 1.2.2.1
    Throttle DVRMStoMPEG
    FWThrottle: C:\Users\Public\Recorded TV\Parenthood_WNBCDT_2010_03_27_19_59_00.wtv
    WaitTime: 0 PollTime
    Duration = 00:00:00
    Waiting for available worker: 3/28/2010 12:23 PM
    Worker allocated: 3/28/2010 12:23 PM
    Get Video Information
    1920x1080 : 1920x1080 ATSC=True
    Duration = 00:00:00.4098035
    Find Commercials in file
    Create Analyzer: ShowAnalyzer
    Use Comskip
    Using comskip
    Running comskip this may take a while.
    Run C:\Program Files (x86)\DVRMSToolbox\Applications\comskip.exe "C:\Users\Public\Recorded TV\Parenthood_WNBCDT_2010_03_27_19_59_00.wtv" "C:\Users\Public\DvrmsToolbox\CommercialsXml"

    Finished Commercial Detectection
    No commercials found
    Action did not complete successfully
    Total Duration = 00:00:15.8912423

    PW Exit: System.InvalidOperationException: No process is associated with this object.
       at System.Diagnostics.Process.EnsureState(State state)
       at System.Diagnostics.Process.get_HasExited()
       at System.Diagnostics.Process.EnsureState(State state)
       at System.Diagnostics.Process.get_ExitCode()
       at Durrant.DVRMSFileWatcher.ProcessWrap.ap_Exited(Object sender, EventArgs e)
     

    Associated XML FILE:

    BODY{font:x-small 'Verdana';margin-right:1.5em} .c{cursor:hand} .b{color:red;font-family:'Courier New';font-weight:bold;text-decoration:none} .e{margin-left:1em;text-indent:-1em;margin-right:1em} .k{margin-left:1em;text-indent:-1em;margin-right:1em} .t{color:#990000} .xt{color:#990099} .ns{color:red} .dt{color:green} .m{color:blue} .tx{font-weight:bold} .db{text-indent:0px;margin-left:1em;margin-top:0px;margin-bottom:0px;padding-left:.3em;border-left:1px solid #CCCCCC;font:small Courier} .di{font:small Courier} .d{color:blue} .pi{color:blue} .cb{text-indent:0px;margin-left:1em;margin-top:0px;margin-bottom:0px;padding-left:.3em;font:small Courier;color:#888888} .ci{font:small Courier;color:#888888} PRE{margin:0px;display:inline}0) fix(e,"cb");} if (e.className=="di"){if (e.children(0).innerText.indexOf("\n")>0) fix(e,"db");} e.id=""; } function fix(e,cl){ e.className=cl; e.style.display="block"; j=e.parentElement.children(0); j.className="c"; k=j.children(0); k.style.visibility="visible"; k.href="#"; } function ch(e){ mark=e.children(0).children(0); if (mark.innerText=="+"){ mark.innerText="-"; for (var i=1;i

    - <root>
      <commercial start="313.613300" end="576.704133" />
      <commercial start="1113.345567" end="1345.527517" />
      <commercial start="1823.524708" end="2035.578217" />
      <commercial start="2305.714750" end="2594.725467" />
      <commercial start="3047.611233" end="3284.384108" />
      </root>
     

     Please let me know if I can provide any other files or information you may need to analyze this. 

     Kind regards,|
     Mike Forgit
     Lindenhurst, NY

  • Mon, Mar 29 2010 5:10 AM In reply to

    Re: Newbie - WMC not skipping commercials with Showanalyzer

    This looks really odd.  It seems that ShowAnalyzer is doing it's job and creating the commercial file, but then the DTB is trying to run comskip as well.  Comskip is what is giving you no commercials found because it can't scan .wtv files.  From the looks of it you are getting the necessary commercial file, but also getting some errors in the log from comskip.  You should be okay skipping commercials in programs.  Have you given it a try?  As long as that .xml file is in the correct location I see no reason why commercials shouldn't be skipping for you.  Obviously you are still getting an odd error.  Let me know if commercials are indeed being skipped.

  • Mon, Mar 29 2010 5:52 PM In reply to

    • Mike F-NY
    • Not Ranked
    • Joined on Sun, Mar 28 2010
    • Lindenhurst, NY

    Re: Newbie - WMC not skipping commercials with Showanalyzer

    Hi,

    Thank you for taking a look at my log files. You know I thought those "comskip" lines in the log looked strange since I had elected to use ShowAnalyzer for commercial skipping.  ShowAnalyzer is writing its XML files to the C:\Users\Public\DvrmsToolbox\CommercialsXml\ folder  I am hoping that is the correct location. I am still not getting any commercials skipped through WMC. I am wondering if I have something checked wrong in the DTB settings that would cause the comskip functions to interfere with ShowAnalyzer.  I will continue to investigate but if any of you seasoned pros have a suggestion I would appreciate the help.  I REALLY want to get the commercial skipping up and running. 

    Kind regards,
    Mike F-NY

     

  • Tue, Mar 30 2010 8:11 PM In reply to

    Re: Newbie - WMC not skipping commercials with Showanalyzer

    Can you test the addin. 

     Start playing recorded show and press the down arrow.  You should get a message box on the screen saying commercial skip is on or off.  If this doesn't happen then something is wrong with your addin installation as well. 

    I assume you've installed the x64 DTBAddin?

  • Wed, Mar 31 2010 3:16 AM In reply to

    • Mike F-NY
    • Not Ranked
    • Joined on Sun, Mar 28 2010
    • Lindenhurst, NY

    Re: Newbie - WMC not skipping commercials with Showanalyzer

    I tried pressing the down arrow while viewing a recorded show as you suggested and two rows of the EPG came up. No message box re: commercial skip.  I did install the x64 bit version of the addin.  I will try to reinstall the addin and see if I get a better result.  Thanks. 

    Kind regards, MjF

     

  • Wed, Mar 31 2010 4:55 AM In reply to

    Re: Newbie - WMC not skipping commercials with Showanalyzer

    Yeah, definitely sounds like a problem with the addin installation. Let me know how it goes. Are you using 1.0.0.5?
  • Wed, Mar 31 2010 6:03 PM In reply to

    • Mike F-NY
    • Not Ranked
    • Joined on Sun, Mar 28 2010
    • Lindenhurst, NY

    Re: Newbie - WMC not skipping commercials with Showanalyzer

    I tried uninstalling and reinstalling the DTB addin and still am not getting any commercial skipping.  After reinstalling the addin I checked the services list in the Windows Task Manager and, sure enough, DTBService is listed under Services as running with a PID of 1824 (not sure what the # means).  I copied the following from the DTBFWService_1824 file that was written to the DvrmsToolbox folder. I can't tell anything from reviewing the output but perhaps someone else on the forum can glean a clue from this.  Meanwhile, I will continue my quest for commercial skipping goodness...

    Kind regards,
    Mike F-NY

    ------------------------------------------------------------------------

    3/31/2010 8:26:43 PM : Ipc Server Listening on ipc://MICHAEL-PC:9199
    3/31/2010 8:26:43 PM : Tcp Server Listening on tcp://169.254.236.59:9199
    3/31/2010 8:26:43 PM : ProcessExe = DVRMStoMPEG.exe
    ProcessArg = /if="{0}" /of="{1}"
    OutputDir = C:\Users\Public\DvrmsToolbox\Output
    ProcessDir = C:\Users\Public\Recorded TV
    WaitTime = 0
    HandleDelete = True
    PollTime = 30
    LogDelete = False
    LogUpdate = True
    LogCreate = True
    LogCheck = False
    QueueUpdates = False
    ProcessedFilePrefix = fileprocess
    NumWorkers = 2
    CleanupDays = 7
    IncludeWatchedFolders = True
    CleanupExt = txt,edl,log
    Port = 9199
    WatchFilter = .dvr-ms,.mpg,.ts,.wtv,.avi
    LogPath = C:\Users\Public\DvrmsToolbox\FWLogs
    VideoTypes = .mpg,.ts,.dvr-ms,.avi,.mp4,.mp4v,.wtv,.mkv,
    MinFileSize = 0
    MinProcessingInterval = 30
    ResetOnDelete = True
    WatchRecursive = True
    ProcessFilesMissingArtifacts = True
    MaxIntances = 5

    3/31/2010 8:26:43 PM :
    3/31/2010 8:26:43 PM : -------------------------------------------------------
    3/31/2010 8:26:43 PM : Start: 3/31/2010 8:26:43 PM
    3/31/2010 8:26:43 PM :
    3/31/2010 8:26:48 PM : FW Begin Process C:\Users\Public\Recorded TV\NBC Nightly News_WNBCDT_2010_03_31_18_29_00.wtv
    3/31/2010 8:27:33 PM : Don't process: C:\Users\Public\Recorded TV\TempRec\TempSBE\{88A203D3-282F-4315-B262-67F68937FF54}.tmp.sbf
    3/31/2010 8:27:34 PM : Don't process: C:\Users\Public\Recorded TV\TempRec\TempSBE\{DEA6ECB4-11B1-4E94-B785-34BFC70FA14E}.tmp.sbf
    3/31/2010 8:29:03 PM : FW Begin Process C:\Users\Public\Recorded TV\The Middle_WABCDT_2010_03_31_20_29_00.wtv
    3/31/2010 8:31:38 PM : Don't process: C:\Users\Public\Recorded TV\TempRec\TempSBE\{6CC1BEF7-07E8-48D8-A75B-973404C4F95B}.tmp.sbf
    3/31/2010 8:31:39 PM : Don't process: C:\Users\Public\Recorded TV\TempRec\TempSBE\{388DD96D-F4DD-4CEF-8755-D3D087A8B79A}.tmp.sbf
    3/31/2010 8:43:59 PM : Don't process: C:\Users\Public\Recorded TV\TempRec\TempSBE\{92220F44-95F3-46C3-9D50-710A803E6583}.tmp.sbf
    3/31/2010 8:48:00 PM : Don't process: C:\Users\Public\Recorded TV\TempRec\TempSBE\{2E3BBAEA-A1B0-42EB-8655-BB80F8E0C667}.tmp.sbf
     

  • Wed, Mar 31 2010 8:48 PM In reply to

    • Mike F-NY
    • Not Ranked
    • Joined on Sun, Mar 28 2010
    • Lindenhurst, NY

    Re: Newbie - WMC not skipping commercials with Showanalyzer

    PROBLEM SOLVED!! I think the problem was I had downloaded an earlier version of the DTB Addin by clicking on the link in the EngadgetHD guide I was using to work through the installation. On the advice of sccrgoalie1, I checked and downloaded version 1.0.0.5, installed it and, lo and behold, SUCCESS!  Thank you for your assistance. Commercials begone!!

    Kind regards
    Mike F-NY

  • Fri, Apr 2 2010 7:41 AM In reply to

    • dabl
    • Top 100 Contributor
    • Joined on Tue, Feb 5 2008

    Re: Newbie - WMC not skipping commercials with Showanalyzer

    Interesting, thanks for the followup.

    I had done the same on my Win 7 64bit install (used the Drawbaugh article) but had purposely used the older versions of both DVRMSToolbox and DTBaddin referenced in that article to avoid the problems described in this thread with one or more later versions of DVRMSToolbox and/or DTBaddin.

    I'm interested in using the current versions and would be very curious if you see the 'cannot skip to end of file' problem with the (see DVRMStoMPEGSettings.exe,Commercial Skip,Suppress Skip Dialog)

     

Page 1 of 1 (9 items)
@2008 andy vt
Powered by Community Server (Non-Commercial Edition), by Telligent Systems