in

andy vt's tools & blog

automating lazy

AVI to DVR-MS failing while retrieving metadata

Last post 04-04-2010 9:01 AM by sbdman. 5 replies.
Page 1 of 1 (6 items)
Sort Posts: Previous Next
  • 03-17-2010 12:54 PM

    AVI to DVR-MS failing while retrieving metadata

    I'm running the profile Convert AVI to DVR-MS - Mencoder and now can't get it to finish.  It gets it to mpg fine and the mpg plays...but then it fails after "Read metadata from TvDB and build Sage XML file".  Yes, I have it set to continue on error, but this is a windows error that says "DVRMStoMPEG has stopped working" and then asks me to close the program.  No logs in windows event viewer.  Not quite sure what's going on.  Can someone please help???

     Error MessageRunning Win7 64, DTB 1.2.2.1

    Log:
    InputFile=C:\Media\Torrents\Temp\Mythbusters.S07E24.HDTV.XviD-OMiCRON.avi
    Processing actions, this may take some time!!
    Current Affinity: 3 System Mask: 3
    Getting MetaData
    File is not a dvrms-file
    Run Profile = Convert AVI to DVR-MS - mencoder
    ProcessId = 6528
    DvrmsToolbox Version: 1.2.2.1
    Throttle DVRMStoMPEG
    FWThrottle: C:\Media\Torrents\Temp\Mythbusters.S07E24.HDTV.XviD-OMiCRON.avi
    WaitTime: 5 PollTime
    Waiting to process file
    Queue file
    Duration = 00:00:01.0180582
    Waiting for available worker: 3/17/2010 12:21 PM
    Worker allocated: 3/17/2010 12:21 PM
    Get the value of Context["OutputFile"] and set the value of Context["OutputFile"]
    Context["OutputFile"] = C:\Users\Public\Recorded TV\Mythbusters.S07E24.HDTV.XviD-OMiCRON.dvr-ms
    Context["OutputFile"] = C:\Users\Public\Recorded TV\Mythbusters.S07E24.HDTV.XviD-OMiCRON.dvr-ms
    Duration = 00:00:00.0030001
    Get the value of Context["InputFile"] and set the value of Context["OutputFolder"]
    Context["InputFile"] = C:\Media\Torrents\Temp\Mythbusters.S07E24.HDTV.XviD-OMiCRON.avi
    Context["OutputFolder"] = C:\Media\Torrents\Temp\
    Duration = 00:00:00
    Run Mencoder
    Run C:\Program Files (x86)\DVRMSToolbox\Applications\Mencoder\Mencoder.exe -quiet "C:\Media\Torrents\Temp\Mythbusters.S07E24.HDTV.XviD-OMiCRON.avi" -profile "MPG-Original-Audio" -o "C:\Users\Public\Recorded TV\Mythbusters.S07E24.HDTV.XviD-OMiCRON.mpg" -vf pp=md,harddup
    MEncoder Sherpya-SVN-r29355-4.5.0 (C) 2000-2009 MPlayer Team
    success: format: 0  data: 0x0 - 0x15da9800
    AVI file format detected.
    [aviheader] Video stream found, -vid 0
    [aviheader] Audio stream found, -aid 1
    VIDEO:  [XVID]  624x352  12bpp  29.970 fps  996.2 kbps (121.6 kbyte/s)
    [V] filefmt:3  fourcc:0x44495658  size:624x352  fps:29.970  ftime:=0.0334
    PACKET SIZE: 2048 bytes, deltascr: 43885
    Opening video filter: [expand osd=1]
    Expand: -1 x -1, -1 ; -1, osd: 1, aspect: 0.000000, round: 1
    Opening video filter: [harddup]
    Opening video filter: [pp=md]
    ==========================================================================
    Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
    Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)
    ==========================================================================
    audiocodec: framecopy (format=55 chans=2 rate=48000 bits=0 B/s=14199 sample-0)
    VDec: vo config request - 624 x 352 (preferred colorspace: Planar YV12)
    [PP] Using external postprocessing filter, max q = 6.
    VDec: using Planar YV12 as output csp (no 0)
    Movie-Aspect is 1.77:1 - prescaling to correct movie aspect.
    videocodec: libavcodec (624x352 fourcc=3267706d [mpg2])
    Writing header...
    INITV: 0.200, 0.158, fps: 23.976
    Flushing video frames.
    Writing index...
    Overhead: 2.431% (24600896 / 1012078272)
    Writing header...
    Video stream: 2988.270 kbit/s  (373533 B/s)  size: 975025412 bytes  2610.274 secs  78229 frames
    Audio stream:  113.593 kbit/s  (14199 B/s)  size: 37063056 bytes  2610.240 secs
    Duration = 00:04:23.9200954
    Move the file in Context["InputFile"] to %OutputFolder%
    File Operation completed
    Duration = 00:00:01.0050575
    Get the value of Context["OutputFile"] and set the value of Context["InputFile"]
    Context["OutputFile"] = C:\Users\Public\Recorded TV\Mythbusters.S07E24.HDTV.XviD-OMiCRON.mpg
    Context["InputFile"] = C:\Users\Public\Recorded TV\Mythbusters.S07E24.HDTV.XviD-OMiCRON.mpg
    Duration = 00:00:00.0010000
    Get the value of Context["OutputFile"] and set the value of Context["OutputFile"]
    Context["OutputFile"] = C:\Users\Public\Recorded TV\Mythbusters.S07E24.HDTV.XviD-OMiCRON.mpg
    Context["OutputFile"] = C:\Users\Public\DvrmsToolbox\DTBTemp\Mythbusters.S07E24.HDTV.XviD-OMiCRON.dvr-ms
    Duration = 00:00:00
    Get the value of Context["InputFile"] and set the value of Context["TvDBXMLFile"]
    Context["InputFile"] = C:\Users\Public\Recorded TV\Mythbusters.S07E24.HDTV.XviD-OMiCRON.mpg
    Context["TvDBXMLFile"] = C:\Users\Public\Recorded TV\Mythbusters.S07E24.HDTV.XviD-OMiCRON.mpg.xml
    Duration = 00:00:00.0010001
    Read metadata from TvDB and build Sage XML file.

     

    After this, it just stops.  If I'm running it manually through the GUI, I get the windows error message.  If run through FW, just the log entry that looks like above.

  • 03-17-2010 1:36 PM In reply to

    Re: AVI to DVR-MS failing while retrieving metadata

    Here's an update.  I was trying to isolate the issue and, since I have some intermediate MPG's, I created a profile that JUST goes out to TvDB and builds the XML.  Still fails, with the same errors.  Following are the steps in my new profile:

    Throttle DVRMStoMPEG
    Get the value of Context["OutputFile"] and set the value of Context["OutputFile"]
    Get the value of Context["InputFile"] and set the value of Context["TvDBXMLFile"]
    Read metadata from TvDB and build Sage XML file.

    Here is the Extraction Regex I'm using:  (?<series>.+)\.[s,S](?<season>\d+)[e,E](?<episodenbr>\d+)\.
    And "ContinueOnFail" is checked, though I don't even think it's getting there. 

    Here's the output (running from GUI, still get windows error message):

    InputFile=C:\Users\Public\DvrmsToolbox\DTBTemp\Chuck.S03E07.PROPER.HDTV.XviD-2HD.mpg
    Processing actions, this may take some time!!
    Current Affinity: 3 System Mask: 3
    Getting MetaData
    File is not a dvrms-file
    Run Profile = Drew's Test AVI to DVR-MS
    ProcessId = 4732
    DvrmsToolbox Version: 1.2.2.1
    Throttle DVRMStoMPEG
    FWThrottle: C:\Users\Public\DvrmsToolbox\DTBTemp\Chuck.S03E07.PROPER.HDTV.XviD-2HD.mpg
    WaitTime: 5 PollTime
    Waiting to process file
    Queue file
    Duration = 00:00:01.0170582
    Waiting for available worker: 3/17/2010 1:31 PM
    Worker allocated: 3/17/2010 1:31 PM
    Get the value of Context["OutputFile"] and set the value of Context["OutputFile"]
    Context["OutputFile"] = C:\Users\Public\DvrmsToolbox\DTBTemp\Chuck.S03E07.PROPER.HDTV.XviD-2HD.mpg
    Context["OutputFile"] = C:\Users\Public\DvrmsToolbox\DTBTemp\Chuck.S03E07.PROPER.HDTV.XviD-2HD.dvr-ms
    Duration = 00:00:00.0030002
    Get the value of Context["InputFile"] and set the value of Context["TvDBXMLFile"]
    Context["InputFile"] = C:\Users\Public\DvrmsToolbox\DTBTemp\Chuck.S03E07.PROPER.HDTV.XviD-2HD.mpg
    Context["TvDBXMLFile"] = C:\Users\Public\DvrmsToolbox\DTBTemp\Chuck.S03E07.PROPER.HDTV.XviD-2HD.mpg.xml
    Duration = 00:00:00
    Read metadata from TvDB and build Sage XML file.

    Thoughts?

  • 03-19-2010 11:20 AM In reply to

    Re: AVI to DVR-MS failing while retrieving metadata

    Ok, the latest: if I take out the call to TvDB, it runs todvrms, but produces a dvr-ms file with no sound.  So I kept hunting.

    I appear to have fixed most of the problems now.  I uninstalled DTB and went back to version 1.2.2.0.  In doing this, it no longer fails on the TvDB call, but an old error resurfaced for AttributeEnable.ax failing on todvrms.exe, which was causing the dvr-ms output files to be cut off (sometimes by as much as half).  So I then upgraded todvrms to version 1.0.1.4 and that fixed the problem of AttributeEnable.ax failing.  Now, if I run toDVRMS.exe by itself from the mpg (made from the whole process), it produces a correct dvr-ms file, with sound, untruncated.  If I run the whole profile through the GUI, I get a dvr-ms with a few minutes cut off.

    Any idea why it would be cutting a few minutes off in the GUI but not when I run todvrms by itself?  The intermediate mpg is fine...full length, so I know it's todvrms that's causing the problem.  Please help!

  • 03-19-2010 1:32 PM In reply to

    Re: AVI to DVR-MS failing while retrieving metadata

    I believe I'm having a conversation with myself.  Oh well.

    Now I'm back to getting a good mpg, but the dvr-ms has no sound.  <sigh>  Running 1.2.2.0 of DTB and 1.0.1.4 of todvrms.  I can produce a dvr-ms from the mpg in VideoRedo just fine.  Thoughts?

  • 03-19-2010 2:48 PM In reply to

    Re: AVI to DVR-MS failing while retrieving metadata

    It works! Ok, so in case someone comes through this thread later looking for info, I fixed the TvDB error by going back from 1.2.2.1 to 1.2.2.0. This then threw an error with todvrms.exe, so I upgraded from 1.0.1.2 to 1.0.1.4, especially the AttributeEnable.ax file. This then produced the correct size files, but had no sound. So I added -msdemux to the todvrms.exe command in the profile and it now works beautifully. And only 3 days of scouring the forums to do it!
  • 04-04-2010 9:01 AM In reply to

    Re: AVI to DVR-MS failing while retrieving metadata

    I'm getting the same problem with this process hanging on the "Read metadata from TvDB and build Sage XML file." point.

    I've also checked off the ContinueOnFail box, but it never get's to take the created mpg file and convert it to a dvr-ms file. I can do the latter part in a dos command window without problem, but it would be nice to have it done automatically as intended.

    Seems from tudrewser the problem lies in the newest 1.2.2.1 version I updated to - it was working for me in the previous version, too. With that version, sometimes it would fail in the metadata retrieval, but, finish the full process with a dvr-ms file.

Page 1 of 1 (6 items)
@2008 andy vt
Powered by Community Server (Non-Commercial Edition), by Telligent Systems