in

andy vt's tools & blog

automating lazy

FileWatcher not using ShowAnalyzer

Last post Sun, Dec 7 2008 6:55 PM by Allen C. 2 replies.
Page 1 of 1 (3 items)
Sort Posts: Previous Next
  • Fri, Dec 5 2008 1:09 PM

    • Allen C
    • Top 150 Contributor
    • Joined on Fri, Dec 5 2008

    FileWatcher not using ShowAnalyzer

    All,

    I've run into a problem with DVRMToolbox FileWatcher and ShowAnalyzer that I'm hoping some of the great minds on this forum might be able to help me with.  I've installed a fresh copy of DVRMSToolBox 1.2.1.5, Show Analyzer 0.9.7.290 on 32bit VMC (6.0.6001.18000 - longhorn_rtm.080118-1840).  Seems to be that no matter what I try, I can't get FileWatcher to use Show Analyzer.  I registered Show Analyzer based on the feedback I read in the forums about its performance vs. comskip and don't recall if Show Analyzer was working before I registered it or not.  I've tried various options recommended in the forums including introducing delays and using the Comskip proxy without any luck.  ShowAnalyzer works just fine manually (start - programs - Dragon Global -). 

    What I'm trying to do is come up with a configuration that will analyze a recording after it is completed, create the necessary skip files so that if I decide to watch the show in MCE it will skip the commercials and create VideoReDo files so that I can review each recording (make any necessary adjustments) and then cut out the commercials.  Based on feedback in the forums and short personal experience trying to tune Comskip and ShowAnalyzer it has become apparent that there isn't a magic config that will work perfectly for all programs so the best (easiest) way I've seen to do this is to use ShowAnalyzer with VideoReDo.  Given the luck I've had tuning ShowAnalyzer and having paid for VideoReDo I'd like to stick with these tools.  As for the mechanics of how to make them work, I'm wide open.

    My current configuration is pretty simple.  I have DVRMSToolbox, Show Analyzer, and VideoRedo installed on my C:\ drive.  MCE records to ...\Public\Recorded TV\.  I have the ...\Public\DVRMSToolbox folders (w/CommercialsXml, DTBTemp, FWJobs, FWLogs, Output, VidoBookmark).  I also have an M: drive where I copy videos off to for archival (free up space on C).  These are videos with commercials trimmed out.

    Frustrated with trying to figure out why FileWatcher won't use ShowAnalyzer (set as default) I downloaded SysInternal ProcessMonitor.  Taking a process snapshot was rather revealing and confusing at the same time.  Process monitor shows reading all of the DVRMSToolbox registry entries including the one that specifies using Show Analyzer.  It then shows DVRMStoMPEG looking and finding the ShowAnalyzer.dll but then going/reverting to Comskip.  The thing that was confusing was that there were a number of entries for a video on the M: drive that I wasn't using/watching/??.

    I've created a zip file that has a log file for a recording (deleted all of the xml and log files then launched one of the recording inside VMC to initiate commecial scanning), a SysInternals Process Monitor Log (PML) file (meat of the log starts at 9:05:17.54... through 9:05:17.84...), Doc with Show Analyzer config screenshots and Doc with DVRMSToolbox config screenshots.   We can't attach files in this forum so I uploaded the file to http://www.hossnet.com/_DTB/FWLogs.zip.

    Any help with this would be greatly appreciated.

    Sincerely,
    Allen

  • Sun, Dec 7 2008 5:40 PM In reply to

    • audiophile
    • Top 25 Contributor
    • Joined on Thu, Sep 11 2008
    • The land downunder

    Re: FileWatcher not using ShowAnalyzer

     

    if you look a few threads down i have the exact same issue. Still not been able to solve it. I have a perfectly functioning custom profile thats uses showanalyzer perfectly on vista x64.

    However when i look at my my VMC when it running poorly, i found each instance of recording seems to run comskip as it is recording and it sucks up 25% cpu per recording so afer 2 at the same time the VMC is rendered basically useless even though i have told DVRMSToolsbox to use the 100% fucntioning profile. I have tried everything and nothing seems to work, and about to pull the plug due to this issue, as it is not viable for a MC with more than 2 tuners running a dual core.

    THis is even the same when running the 64 bit version of file watcher.

  • Sun, Dec 7 2008 6:55 PM In reply to

    • Allen C
    • Top 150 Contributor
    • Joined on Fri, Dec 5 2008

    Re: FileWatcher not using ShowAnalyzer

    When I couldn't get FileWatcher to use ShowAnalyzer I decided to try Dragon Global's DirMon2.  Installing and configuring was easy but jobs set up to use ShowAnalyzer would fail.  These jobs would generate a log file in the ShowAnalyzer directory that indicated ShowAnalyzer was running in Free Mode even though I had registered it and ...\settings\mode.status said 'normal'.  Frustrated I figured I'd give it one more go.  I did the following:

    1) Stopped the FileWatcher service
    2) Stopped the DirMon2 service
    3) Uninstalled the DirMon2 service via the DirMon2 gui
    4) Uninstalled FileMon2
    5) Uninstalled ShowAnalyzer
    6) Deleted the ...\Program Files\Dragon Global\ directory
    7) Rebooted
    8) Installed DirMon2
    9) Installed ShowAnalyzer
    10) Registered ShowAnalyzer
    11) Verified DVRMSToolBox was still set to use ShowAnalyzer as it's default
    12) Test a recording in VMC

    It worked fine.  Not sure if it was one of my ShowAnalyzer INI files or something hokey in my mode.status file but I'm back in business.  Now I'm slowly building up my INI files and testing all the way.  Hopefully this will help someone else.  I know VMC 64bit has other considerations but....

    Sincerely,
    Allen

Page 1 of 1 (3 items)
@2008 andy vt
Powered by Community Server (Non-Commercial Edition), by Telligent Systems